Jump to content

Problems with my Outboard: Lost my high end rpms


badfish

Recommended Posts

I recently put my boat in, first 3 trips, at about an hour each, motor ran perfectly. On the 4th trip, I had 5 people including myself on my 22ft bayliner trophy with a 1994 150 evinrude v6 outboard. A half hour into the trip, while in some moderate chop, I had the throttle wide open and my rpms slowly dropped in about 30 seconds from 4000 plus to about 3100 rpms(35mph to 20 mph). Currently the engine runs smooth and consistent, but I cannot run over 3100 rpms. I checked the fuel line, fuel filters, cleaned carborators, all  of my spark plugs are working. Discovered that a couple of my spark plug boots are corroded and do not grip well the the plugs. Also suspecting that I may have somone weak coils.

 

Anyone have an experience similar to this? Or any tips?

 

Link to comment
Share on other sites

It sounds like you have a maintanance issue to take care of so the computer set the rpms that low so you don't damage the motor. I don't know if your gauges are equipped to give out maintenance codes? if not a maintenance manual for your motor is invaluable. also you can post your question  on  ( I BOATS .COM). Find the link to your specific motor and post a question there,They are very knowledgeable and helpfull

 

Good luck.

Edited by rebar
Link to comment
Share on other sites

Sounds like the high speed fuel pump is gone. There simple but expensive fix about 300$ in parts. Happened on my Honda couple years back.

high speed fuel pump? its an 94 evinrude 150 v6, would the fuel pump be connected to the filter/?

Link to comment
Share on other sites

It sounds like you have a maintanance issue to take care of so the computer set the rpms that low so you don't damage the motor. I don't know if your gauges are equipped to give out maintenance codes? if not a maintenance manual for your motor is invaluable. also you can post your question  on  ( I BOATS .COM). Find the link to your specific motor and post a question there,They are very knowledgeable and helpfull

 

That sounds possbile but i dont know if the motor has an computers like that or not given its age, there is defintely a problem that is casuing the engine not to perform at its highest capacity

Link to comment
Share on other sites

Check your timing advance. Sound a lot like an ignition spark advance issue. Probably built into the ignition module

 

Check your timing advance. Sound a lot like an ignition spark advance issue. Probably built into the ignition module

how can i check the timing advance?

Link to comment
Share on other sites

You need a shop manual !! I believe this motor has optical ignition system and is diagnosed with a laptop and a special program . You might want to check your shift interrupter switch , that will kill one bank of cylinders . Also ,did your engine get hot ? It has a sensor that limits rpm if engine gets too hot . Rev limiter may be bad etc. etc . Technology is great when it works .firgot to add you check timing advance with an automotive timing light while engine is running. Check manual for timing marks and specifications

Edited by chinook35
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...