Jump to content

Recommended Posts

  • 4 weeks later...
  • 2 weeks later...

Happened to take a drive there 2 hours ago, main dock is there but the other launch docks are still sitting

on land. No sign of movement, the Shack is still all closed up to, no web cams working yet, the city said 2 weeks ago they would be up and running very soon, only doing Maintenance on them. Well that's been going on since last August.

 

To nasty to get out there right now.

Link to post
Share on other sites

I was there 3 hours ago,Main docks are in,the boat launch one short one in the rest still out,shack is still closed up.No web cams to see anything yet. Suppose to be on,if any one is concerned about what the lake is doing before they get there I suggest calling the Mayors office in Oswego or your local Alderman.Waves tonight where around 1-2 feet,they were hitting the breakwall. Fridays weather is looking ok. Rain is in the forecast for the weekend and possible storms.

Link to post
Share on other sites

With the weather they had,they certainly could have put them in earlier,I heard they have to schedule the workers time to do the docks job,move them from a winter position to a summer one.


Sent from my iPad using Lake Ontario United

Link to post
Share on other sites

There's no reason to be discouraged from launching at Wright's. Smaller boats have been for a couple weeks and we put my 28' in Saturday. You don't need the center dock to get in the water...

 

The marina doesn't officially open until May 1st. Right now you get what you are getting charged for, nothing for nothing.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...