Jump to content

2013 Mercury Pro Kicker Trim Motor Problem


Recommended Posts

2013 Mercury Pro Kicker Trim Motor Problem

Trim Motor is Making a noise when raising and lowering as if its starving for oil at first it seemed to only do it in cold weather but last week it was warm and also made the noise pulled the fill plug and oil level is good actually seemed a little over filled no sign of water in oil could motor be going bad? Any input before I take it to dealer would be appreciated. Thanks

Link to post
Share on other sites

As far as I know it is normal for them to make noise when raising and lowering (at least on bigger motors) and I Ithink they usually just stop responding period when they are shot and it is usually the button on the motor that has that problem. Is the noise radically different than what it has been since you got the motor?

Edited by Sk8man
Link to post
Share on other sites

Hey Les Thanks for the response the motor is not a 13 like I put its an 11 time going by way to fast I really don't recall the motor ever making the noise the first couple years until  last year with the early start and really cold mornings, it was ok the rest of the summer then the other day it was a little chilly but not cold by any means and it was doing it just doesn't seem right, the dealer where I bought it is almost fifty miles away just wanted to get some input before I drive all the way there.

Link to post
Share on other sites

Ah OK Lee. Hopefully someone else has been through the situation on here and has an idea. I kknow it sure is frustrating to have motor problems of any kind. Good luck with it. Les

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...