Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
ERABBIT

Seneca Lodi Point State Park Launch 4-22-2017

Recommended Posts

I launched there yesterday to put boat in hoist  for the year.  Launching was ok.  Lake was pretty rough out of North.  Lots of debris in water.  Lake temp. 46 out deep, 42 under dock.

Share this post


Link to post
Share on other sites

Sampson looked better last week. Same conditions at launch ramp. Logs and debris. Who knows when the state will come in and clean it out.

Share this post


Link to post
Share on other sites

Just something to think about regarding the debris in launch ramp...... I had a stick get caught in between the hull and one of the bunks without seeing it while loading my boat at the Canandaigua launch and didn't see it until the carwash and then too late broke the front of the bunk at the support fitting @#$^*:envy:

Share this post


Link to post
Share on other sites

Bill took that picture on Saturday no Park guy on the weekend. For the past 8 to 10 years when I was over there I did have to use my grain shovel to clean ramp , one of the Park guy took care of it daily during the week.......

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...