Jump to content

Recommended Posts

Does anyone run leadcore when fleas are bad? I sort of remember having trouble with fleas last year on my leadcore in Cayuga. Anything you do to get rid of them or just don't run them all together? I have sea flee for leaders but that is only part of the problem. 

Link to post
Share on other sites

I think in terms of the severity of the problem part of it may relate to the type of fleas encountered and the particular concentrations of them as they aren't uniformly distributed  throughout the body of water. The Sea Flee has a slippery coating on the outside of it that seems to shed the fleas pretty well but the leadcore sheathing is course and textured allowing them to cling to it real well. I don't use the cores during the peak flea season and shift to just the coppers and riggers which usually don't seem to get as badly infested, but when the fleas are very thick even rigger wires can become clogged with them.

Edited by Sk8man
Link to post
Share on other sites

They do in some  the Finger Lakes Paul and I think the ones that may be a proiblem could be different than the usuals on Lake O and even the rigger wire can be affected which makes me think some of them may be a different variety and/or more dense concentrations.

Edited by Sk8man
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...