Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Recommended Posts

Posted (edited)

Drove up to Mexico on Thursday morning, got there around 9 am . Wind blowing hard from NW over 15-20 mph . Huge waves . So we didn’t fish .Friday , Got to the launch around 6 am , 2 boats came in . I talked to a guy on the boat, he said it’s very rough. I asked how bad was the waves , he said 3 ft with 5 and 6 ft . So to make a long story short , I went out. It was rough . Found temp in 220 fow 90 ft down , but never moved a rod . Only fished a few hours , was getting beat up from the waves . 


Sent from my iPhone using Lake Ontario United

Edited by p3434
  • Like 2

Share this post


Link to post
Share on other sites
Posted (edited)

That’s tough. Those days go to Oswego and fish inside the breakwall or fish otsego 

Edited by Adk1

Share this post


Link to post
Share on other sites

Or drink beer


Sent from my iPhone using Lake Ontario United

  • Like 1

Share this post


Link to post
Share on other sites

Launched out of Mexico yesterday at 6a. Ran out in front of the SR and started a N troll out to 150'. Picked up 1 17lb King. Ran out to 370 fow, went 1 for 3. With no down temp really struggled to find any fish. Hopefully the west winds this week will bring some back our way!

Sent from my XT1650 using Lake Ontario United mobile app

Share this post


Link to post
Share on other sites
Launched out of Mexico yesterday at 6a. Ran out in front of the SR and started a N troll out to 150'. Picked up 1 17lb King. Ran out to 370 fow, went 1 for 3. With no down temp really struggled to find any fish. Hopefully the west winds this week will bring some back our way!

Sent from my XT1650 using Lake Ontario United mobile app


Fished satday from 80 to 200 . 2 hits 1 fish 19lb 20180811_090144.jpg

Sent from my SM-G920V using Lake Ontario United mobile app

Share this post


Link to post
Share on other sites

My son and I fished Sat out at 7:30 went 1 for 2, landing an 18lb king but losing a 9lb at the net both on Copper. Sunday out at 7:45 went 0 for 1 losing fish and FF, broke line during fight.  We were N/NE of Oswego in 350 - 500 FOW temp was at 65 - 70. Will be back up there on 8/23.

Share this post


Link to post
Share on other sites

We went 7 for 10 all on riggers Saturday 50 degress down 100 in 8 hrs of fishing in 300 FOW Saturday and 4 for 5 in 450 FOW Sunday in 5 hrs 1 on copper rest on riggers.

Edited by Andr3wxmma

Share this post


Link to post
Share on other sites
36 minutes ago, Andr3wxmma said:

We went 7 for 10 all on riggers Saturday 50 degress down 100 in 8 hrs of fishing in 300 FOW Saturday and 4 for 5 in 450 FOW Sunday in 5 hrs 1 on copper rest on riggers.

How many foot of copper were u runnin , thinkin of bringin 300 400 next trip

Share this post


Link to post
Share on other sites

Headed up tonight, any action by the plant? Wondering if should start in close or out deep still tomorrow? Any help would be great thanks 

Share this post


Link to post
Share on other sites
Just now, nick13 said:

Headed up tonight, any action by the plant? Wondering if should start in close or out deep still tomorrow? Any help would be great thanks 

The wind report is saying to stay on the doc 😂

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×