Jump to content

Cannon mag 10 STX stopped working


BrokeOff

Recommended Posts

Fish strikes 110 down 15# weight. I hit the switch as we battle fish. Land it and realize the rigger never came up..... should be at the surface buts still 100 ft down. Tried reset button and other cannon outlets. Nothing. Ended up bringing up by loosening clutch and spinning wheel by hand. Took a break at 40ft to go. After resting for a while I realize the knob is spinning and probe and ball come to surface!? But it still won’t work. Figure maybe voltage issue. After running back to dock it still won’t work tho? Any ideas? Is the board fried?

Link to comment
Share on other sites

Probably the switch. Mine started acting up mid season, some water got into the housing from the open rod holder bolt hole on the outside. Took it apart and switch was all corroded. Cheap fix.


Sent from my iPhone using Lake Ontario United

Link to comment
Share on other sites

When the board goes, usually up or down will not work.  Most of the time one will work and the other will not.  The plug connections have been known to break in the plug if you plug them in and unplug them a lot. 

Link to comment
Share on other sites

If the other rigger works in the bad rigger plug, its likely not the plug.  Take off the 8 bolts or however many it is on the side panel and check out the switch and the board.  If they are bad, you will likely see a noticeable issue with them.  My guess its the switch.  Mine started acting the same way.  I only ever ran one rod holder on it, which leaves one bolt hole open where the second rod holder would go.  After i ordered the switch (https://www.fish307.com/cannon-downrigger-part-2286792-switch-shortstop-3-prong/) i also ordered a second rod holder to prevent this issue.  only happened to one of my two riggers though, the starboard side with the open bolt hole to the outside of the gunwale, likely from running cross-wave in rough conditions.  Here is what my switch looked like.  Obvious moisture in there too, but board looked fine.  Switch kinda sits in the lowest portion of the housing, thus getting all the moisture pooled up on it

IMG_0112.jpg

IMG_0113.jpg

Link to comment
Share on other sites

  • 2 weeks later...

One fix that cannon recommended for intermittent problems was to spread the male pins on the power cord to gain better contact with the female end.  You can run a Q-tip inside the female connector sleeves to clean any corrosion building inside the contact.  Another thing to consider is your splice connections. Sometimes it takes cutting and splicing in new crimp connectors (adhesive lined).  Lastly, if you run a kicker motor and don't run off the main, your battery charge may be dropping too low during trolling.  The mother board does not like running on voltage too low and can blow.

Link to comment
Share on other sites

  • 1 year later...
On 8/24/2018 at 1:57 AM, Gill-T said:

 Lastly, if you run a kicker motor and don't run off the main, your battery charge may be dropping too low during trolling.  The mother board does not like running on voltage too low and can blow.

I just re-read thru this thread, I think you are on to something here. I am up to 3 fried boards in my cannons now.  Sometimes while dropping a rigger my electronics will go off due to the draw

Link to comment
Share on other sites

Another thing I did to my cannons was change from the stock cannon two prong terminus to a Minn Kota receptacle termination.  Better connection, heavier gauge wire.  

Link to comment
Share on other sites

Broke off i have had the same problem i have had three board,s go ,one last fall and two when i put the boat in this spring if i,am not mistaken they seemed to go bad over the winter they were in my warm basement,but i will check the voltage,s on my battery,s they were charged when i put them in the boat.The board,,s were on three different rigger,s.

Link to comment
Share on other sites

  • 1 month later...

Familiar problem. I am helping a neighbor with a 5ST. Same inside as a 10 STX. Wont run after the winter in the garage. I noticed the relays clicking when pushing the switch up and down. Pulled the cover, could feel the relays pulsing when switched. Thought it may be the motor. Pulled wires off the board and jumped to 12v directly. Motor worked fine. Interesting. Checked voltage at the board on the motor terminals with a meter.
+12 in one direction and -12 volts in the other. Now very interesting!
All looks good. STILL WONT RUN. Drawing on 42 years of experience with machine controls I am betting one or both of the relays are cooked. The contacts allow enough current flow to be useful for the meter check but any large current draw to run the motor will not happen. I have seen this before. This is a common problem on relays used on winches.
I haven't taken the board out yet but I am betting the relays are soldered and encapsulated in epoxy on the back side. I have carefully replaced them on an old Mag 10 years ago. This time the neighbor will be buying a new board.



Sent from my SM-J737V using Lake Ontario United mobile app

Link to comment
Share on other sites

I have heard and seen from many people that insufficient juice will put a Cannon downrigger in the hurt locker. Dropping with the motor, is not so bad, but the draw on the way up will fry a board if the charging system is not up to the task.

Sent from my moto z3 using Lake Ontario United mobile app

Link to comment
Share on other sites

New control board arrived today. No encapsulation on the wave solder joints on the bottom of the board. Can easily de-solder and replace relays. I will be ordering some relays on line to repair the old control board. Everyone with this problem should save their old board since they can be repaired.

Sent from my SM-J737V using Lake Ontario United mobile app

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...