Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Akromion

Members
  • Content Count

    1
  • Joined

  • Last visited

Community Reputation

0 Neutral

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Hello, I'm wondering if some one could help me. Hello, I have 2 Cannon Digitroll IV where one of them works great but the other one doesn’t work properly. The one that doesn’t work is that the display works and I can get through the menu but when I drop the Cannon ball the display show the same number depth zero number. Example I have set the depth zero to -3 feet and it will stay at that number all the time regardless of me raising it up/down the cannonball. I also notice that it was raising up/down with a small jigging speed where it was slowing down a little bit like in interval. Don’t know if it some kind of settings for that. I have tested the circuit board from the one that works on the DT that doesn't work and it can count. Then I have tested the circuit board that's wrong on the other DT and it's the same problem. So I'm quite sure it's the circuit board that's wrong. The preowner have open the lid to change wires and I could see a little bit corrosion on the backside of the board. Is it any of the component I could look for to see if it's broken? Do any have suggestion what is wrong with the downrigger and if it's something I can try to fix the problem?
×
×
  • Create New...