Jump to content

Tim G.

Members
  • Posts

    35
  • Joined

  • Last visited

Everything posted by Tim G.

  1. Electric start ? Can you call me 716-238-1712. Id like to see it. Thanks
  2. Yep I had a guy text me yesterday saying he had a one year old fish hawk more than half off. Lmao. I asked him if I can call him to chat and he said he would probably be busy. Also had a Chicago area code but gave me an address from Maryland. Definitely a scam. And his wordings in the text were repetitive. Also when. I asked for how it performed for him. He gave me a word for word description off the website. Beware. People. Pieces of Sh#t are everywhere trying to scam
  3. Looking to buy a fish hawk or sub troll does anyone have one for sale. If so give me a call or text please. 716-238-1712
  4. Fortrex 36 volt 109 thrust 45" shaft. Built in transducer Must sell 500$ firm.
  5. 2013. 45" shaft. I do not have a remote just a pedal
  6. Like new 36 volt 109 thrust minn kota fortrex bow mount trolling motor for sale. I purchased this and its not right set up for my boat. 500 firm.
  7. I finally got my answer to the overheated engine. I took the head off to inspect the pistons and the sleeve on cylinder 2 has twisted . I was told by the dealer that the block is now junk. I've already got another motor installed on the boat this weekend . Thanks for everyone's help. As I said before I was hoping for good news but this is by the worst case scenario
  8. Yes I know it overheated. My alarm was going off for a while to get back in to shore. That being said. U can see that the motor got so hot it melted plastic connections on some of the wires laying on the topic the motor. And the seam where the block meets the intake has apparent melted paint. I am getting a second opinon Thursday from the johnson dealer. Ill get back to you guys then. At this point ive started to look at used motors in case the motor needs an overhaul for sure and its over my head in diy or cost . Well see . Thanks everyone
  9. He said he sprayed ether on block while it was running and it sucked it in and motor stopped. So a vacuum leak is apparent there. That would mean its a gasket or seal where the blocks come together i believe
  10. My mechanic said it has some internal damage from over heating. He's given up and said not worth investing anymore 😕
  11. Shop said that it overheated when the impeller went and caused internal damage. He invested alot of time into it and stopped because he new it wasn't an easy fix and didn't want to spend anymore time on it. Only charged me 100$. Im not convinced though that it's internal damage because there is no way in hell it would go from running bad to running great the next day to back to bad the next weekend if that was the problem. Second opinion is next to do
  12. I have 3 coils. Did I bench test with n ohm meter. Had the same reading on all three. I definitely have spark but maybe just not timed right. I've eliminated all gas issues and carbs. I got a manuel and testing requires all these make shift tools and meters
  13. It doesn't cut out n die. It just doesn't get on plane. Basically running on only one or two cylinders. 7 mph tops. Very boggy. Not enough fuel gonna look into fuel pump replacement or repair kit
  14. The spark plugs are champion. White n silver. And i did a compresion test and all three cylinder were the same around 100
  15. Its a 2 stroke . I have ran new gas through a small can , changed plugs. Rebuild all three carbs, changed the gas line from tank to motor. Checked the smaller lines for blockage. I definitely want to check the exhaust for blockage next and if thats not it I'm suspecting an electric issue
  16. thank you. Thats what I was gonna try today. The fuel filter seemed fine. I took it off and blew through it with ease.
  17. I did drain the tank last Sunday morning. Figured I was out of the woods when it ran good after but yesterday and today. Ran like crap
  18. looking for any pointers on solving my issue. Last Saturday I put in reservation gas. Then the boat would stall out while trolling. When I picked up a moved I realized the boat would only go 7 mph not 30. I suspected fouled plugs. Changed them and ran well tol fouled again. Next day I removed all gas. And changed the plugs .was running back to normal. Fast forward to yesterday and she was running rough again. Changed plugs. Ran seafoam though a gallon of gas. Sprayed carb cleaner in carbs. One plug seems to foul out more then others so I concentrated on that carb. Took it off. Cleaned it and put it back together. I did not pull out the needle cause I didn't have a replacement yet in case I lost a piece. Still running bad. I have spark at all three plugs. Sounds like too much gas or maybe air in the line somewhere. But why did it run good sunday but not today. Uhh
×
×
  • Create New...