Jump to content

Merc 3.7 Liter battery/charging issue


Recommended Posts

I have an 18' Penn Yan with a Mercury 3.7 liter I/O. I was out running Sunday trolling around and my motor started running crappy and stalling at trolling speed. I though it was a fuel problem but as I was pulling it out of the water I tried to start it and the battery was very weak and barely started the motor. I got home, threw the ear muffs and battery charger on it. I started it up and tried the old trick where you start the motor and pull the ground connection off the battery to see if it stays running.

It did stay running but immediately stated idling very poorly and barely stayed running. As soon as I touched the ground cable back to the battery it would purr like a kitten. I then revved it up to about 2500 rpm's and pulled the cable off. As son as I pulled it off it started running crappy again but did stay running. Put it back on and purred like a kitten.

Anyone ever heard of this? seems like my magneto is only charging about 1/2 power. Charging enough to spark but not enough to give a full spark. I did put a meter on the output side of the magneto and did get about 12 volts. I also put my meter on what I think is the output side of my voltage regulator and got 14 volts.

Any ideas or suggestions of things to try?



Link to comment
Share on other sites

I have a used voltage regulator that I got from hank last year to finish up the year. I put a differant alt on mine . Mine was overcharging to the tune of 16+volts :@ The reg new is pretty pricey. Have stator ring too.

Link to comment
Share on other sites

  • 3 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...