Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Recommended Posts

post-151579-0-05068500-1367769673_thumb.jpgDock is in and ready to go. Only saw about 4 fishing boats all day. I was out in varying depths 60-160 fow. I went over past Humber Park and back toward the CertainTeed Gypsum Plant at Clarkson and back to PC, …..Nothing.

 

 

 

Got to test out my new Cannon Mag 10. What a life saver from my hand crank, as I have tendonitis

 

in my right bicep. Worked great, no problem with the auto stop when the weight comes out

 

of the water so it must have been grounded properly. I did have to add some aluminum gusset/brackets.

I mounted the Mag 10 on a 6" pedestal on the gunwale track. The unit itself approx. 25lbs plus the cannon ball 12lb. hanging 3’ over, so there was some deflection on the gunwale. It would have eventually led to some damage. So I installed pieces of aluminum angle bar stock from Lowes $13 ea. approx. 18" long from the mounting plate at the top of the pedestal

to rear deck and you could tow a tank with this now. Worked on it last night and completed in about 2 hrs.

 

 

 

Nightrainzzz

 

16’ Legend

 

75hp Merc

 

 

 

 

 

 

post-151579-0-73870600-1367769695_thumb.jpg

post-151579-0-84859600-1367769731_thumb.jpg

Edited by nightrainzzz

Share this post


Link to post
Share on other sites

I went out about 3 times last week. Went from Lakefront to the huge docks/commercial ships west of port credit and did not get a single bite. Buddy of mine wss fishing for browns at 401. I guess the fish are not here yet

Share this post


Link to post
Share on other sites

I was out in grimsby today fishing 30 feet to 180 feet. Had two tip ups but no hool ups. Been slow but the water is starting to warm to a nice temp. Hopefully things start heating up next week.

Share this post


Link to post
Share on other sites

The high retrieval rate does cause some problems especially 5.5ft out with a 10 or 12 pound ball on the end. I also had gunwale deflection that I had to reinforce for. I hope you didn't get the swivel pedestal, I had to take mine back last year after less than a season... The swivel was getting way too much play... Not built for that kind of torque I guess. I'm from Sudbury but went down to St Catherines last weekend... I posted my report in the South (American) blogs if you are interested. We did well.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...