Jump to content

Sold / Closed Cannon Mag 10 Parts or rebuild


Recommended Posts

Hi folks,

 

I have a Cannon Mag 10 that has been on a shelf for a couple of years. Looking to get rid of it. It has the old style power cable, and no down rigger cable. Has a single rear rod holder, and the retro ease retriever system. I have hooked it to a 12v power supply, and it functions, just not sure if it’s all there. Anyway, $50 and it’s yours. Pick up only, Watertown area.

 

Thanks for looking -RustyIMG_0117.JPGIMG_0118.JPGIMG_0119.JPGIMG_0120.JPG

 

 

Rusty

Edited by L&M
Edit item description
Link to post
Share on other sites
  • 7 months later...

Just fyi but I don't think that is a mag 10A, I believe that is a regular Mag 10. Possibly a Mag 10a that was converted to use the Mag 10 motors, if you pull that cover off I'd bet you will see a flat sided motor where the mag 10A had a round body motor and different shaped housing.

Edited by FishingFool34
Link to post
Share on other sites
2 minutes ago, rusty1034 said:

Thanks for having my back guys.

The unit is a Magnum 10.


Sent from my iPad using Lake Ontario United

:yes: Those mag 10 motors are very hard to find and the telescoping boom is compatible with almost all other models of that generation. It's worth your asking price in parts all day. Goodluck!

Link to post
Share on other sites
:yes: Those mag 10 motors are very hard to find and the telescoping boom is compatible with almost all other models of that generation. It's worth your asking price in parts all day. Goodluck!
Just yesterday I paid 54 dollars for two of the pulley assemblies on the boom and was glad to get them. Had riggers upgraded a couple years ago to newer motors and the heavier power cords. Still great units

Sent from my Moto E (4) Plus using Tapatalk

Link to post
Share on other sites
:yes: Those mag 10 motors are very hard to find and the telescoping boom is compatible with almost all other models of that generation. It's worth your asking price in parts all day. Goodluck!



In case it wasn’t clear in the original post, I’m not sure if the motor is operating correctly.


Sent from my iPad using Lake Ontario United
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...