Jump to content

Recommended Posts

I had the same problem with my radio. It turned out to be a poor ground(corrosion). Cleaned all connections and it worked great. I couldn't see the corrosion until I removed the ground wire from my terminal block.

High Bidder

Link to post
Share on other sites

My connections are good. I recently reterminated the antenna, good connection there. My Mic has controls built in they don't work either. There is no feed to the radio.

Who said I was talking to you Nick.Lol

[ Post made via Android ] Android.png

Link to post
Share on other sites

After calling straight to cobra today and finding out that the 3 yr warranty is only good on the radio itself. :@ The price of the mic was about 1/3 the price of the radio. :o After a brief argument :devil: I have a brand new mic on its way compliments of Cobra. :clap: I'm not one to walk on people but I can't stand getting stepped on! BTW Standard horizon has a $20 rebate available for some of thier VHF. :lol:

Link to post
Share on other sites

You know me Nick, I think I'm pretty cool tempered easy to get along with. That guy told me that my 3 yr warranty only covers the radio and that if it got wet its not covered. That Mic is advertised and listed as submersible but if it doesn't work they don't care. I got a little hot with him. Sometimes I guess you have to.

[ Post made via Android ] Android.png

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...