Jump to content

Cannon Mag10STX switch question


Recommended Posts

Our probe rigger has started acting up. First, it began coming to a stop slowly on the descent so that it ended ~2 ft below where you stopped pushing the switch down. Then a couple weeks later it began to freeze up and not go down until you pushed the switch up again. It's intermittent, but I want to fix it prior to storage if possible. Has anyone else had this type of issue? I ordered a new three prong toggle switch from Fish307. Hopefully I won't have much difficulty replacing it myself and it will do the trick. Thanks in advance for any advice.

Link to post
Share on other sites

These riggers are very easy to service yourself. I had the same problem with my Mag 10 H/S's. Go to fish 307.com download the schematics for you rigger and get part numbers and order from them...cheapest around for cannon parts. I replaced my board....installed a new switch...Just remember what wires have been removed and then "plug-n-play" I also changed the rigger power cords and battery cords to new style.  While I had the rigger open...I replaced clutch pad and totally re-greased the gear box. Then I changed the thrust bearing and washers and re-greased...very simple to do yourself...unit is back to new condition.  

Link to post
Share on other sites

Good to know. I updated my order to include thrust bearings, washers, clutch pad and switch from Fish307 today. What type of grease did you use? Thanks

Link to post
Share on other sites

Good to know. I updated my order to include thrust bearings, washers, clutch pad and switch from Fish307 today. What type of grease did you use? Thanks

If you need help Keith, I have done a lot of boards over the years.  It is simple. 

Link to post
Share on other sites

FYI...friend of mine just ran into same trouble. cannon uses the same rigger body for the digitroll's so under the "sticker" on the top where the buttons for digitroll would be there is a hole where they run the wires thru. if any of that sticker starts to peel up as his did just a little in one corner...your rigger will fill with H20 and fry you switch and board! his had 2" of H20 in it when took side cover off to change board! I placed small bead of silicon around mine after seeing that!

Link to post
Share on other sites

FYI...friend of mine just ran into same trouble. cannon uses the same rigger body for the digitroll's so under the "sticker" on the top where the buttons for digitroll would be there is a hole where they run the wires thru. if any of that sticker starts to peel up as his did just a little in one corner...your rigger will fill with H20 and fry you switch and board! his had 2" of H20 in it when took side cover off to change board! I placed small bead of silicon around mine after seeing that!

I thought I was the only person to have this problem. Beware the sticker! Luckily it was covered under warranty.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...