Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
FishingTheFL

Oops Got the moisture out... Pulled the wires.

Recommended Posts

Any Old Apleco 365 display units out there? If so can any one take a picture of the wires... Or want to sell it? Tool mine apart, left on dash to get condensatio out, forgot to put it back together... And well.. Wires pulled out... I probably should just upgrade... But that means pulling old transducers and filling holes in my aluminum boat... Figure I would try here before starting a headache

1501846056111.jpg

 

Sent from my VS425PP using Lake Ontario United mobile app

 

 

Share this post


Link to post
Share on other sites
1 hour ago, FishingTheFL said:

 

." I probably should just upgrade... "  Mike I think you provided your own best solution in that statement:lol:

 

Sent from my VS425PP using Lake Ontario United mobile app

 

 

 

 

 

Share this post


Link to post
Share on other sites

Let me check I think I have that model and one prong broke off on the back, I don't use it I have to work today until 8 but I'll check when I get home.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×