Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
boomer1

Yamaha 9.9 four stroke

Recommended Posts

I have a Yamaha 9.9 four stroke for a kicker it runs great for the better part of the day then all of a sudden starts to sputter and quits after I get it restarted it seems to be running on one cylinder!  Anyone experience this issue and if so what was your fix?

Share this post


Link to post
Share on other sites

Check the fuel line fitting where it connects to motor- the o rings can fail so it sucks air.  It is piece I have replaced.  Look at primer bulb and fuel line especially if you have used fuel with ethanol.  If those items check out- might have to clean carb.

Share this post


Link to post
Share on other sites

Yes it is running off the main fuel tank and I will check all the fittings.  I also have a water separator between the fuel tank and both my main and kicker.   Thanks for the advice

Share this post


Link to post
Share on other sites

Had a similar intermittent problem when hooked to the main fuel tank. Tried a check valve and that helped but still happened on occasion. Just to prove a point, I would run the 9.9 off a small outboard type tank for a while.

Sent from my SM-J737V using Lake Ontario United mobile app

Share this post


Link to post
Share on other sites

I had check valve and it was worse I will try a new primer bulb and hose as well as the fitting to the motor hopefully that will work.  Something to start with I guess.

Share this post


Link to post
Share on other sites

sounds like the inner lining of the gas line is collapsing inside itself. the new gas line will fix the problem if thats what it is.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...