Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
reel retirement

Fish hawk x4d problems

Recommended Posts

I am having an issue with my fish hawk x4d. It is only the second season for it this year, and the down temp says its 75 degrees and surface temp is at 58 degrees pretty sure this is not right also the blue tooth is not working to my phone. This has only been used about a dozen times and I always keep the probe in its case and it was stored in my house all winter with the batteries removed. Has anybody ever had this problem? 

Share this post


Link to post
Share on other sites

Make sure your fishfinder isn't running on a similar frequency. My Garmin will screw up the fishhawk running on 77hrz

Share this post


Link to post
Share on other sites

call them while your out on the water they will trouble shoot  with you  and get you running properly they are very good with customer service

  • Like 1

Share this post


Link to post
Share on other sites

Mine, and my buddies have never worked as advertised. Hit or miss at best and we have both gone through their tech dept. and sent videos of the screen. Follow the calibration process and it sometimes makes it more believable and sometimes not. Certainly haven’t gotten mine reliable yet unfortunately.


Sent from my iPhone using Lake Ontario United

Share this post


Link to post
Share on other sites

I had problems with mine and I fixed it I have an outboard motor and what the problem happened to be was the spark plugs believe it or not, the spark plugs were creating an electromagnetic field interfering with the signal of the Fish Hawk so I ordered resistor spark plugs and it fix the problem

Sent from my SM-A102U using Lake Ontario United mobile app

Share this post


Link to post
Share on other sites
I had problems with mine and I fixed it I have an outboard motor and what the problem happened to be was the spark plugs believe it or not, the spark plugs were creating an electromagnetic field interfering with the signal of the Fish Hawk so I ordered resistor spark plugs and it fix the problem

Sent from my SM-A102U using Lake Ontario United mobile app



Interesting. Was it your kicker? What size and brand?


Sent from my iPhone using Lake Ontario United mobile app

Share this post


Link to post
Share on other sites

1991 80hp merc , spark plug is ignited it produces electricity, a regular spark plug has a frequency between 60 and 120 hertz the Fishhawk runs on 70 hurts and your fish finders run from 120 hertz and up depending on your model the resistor plugs have an insulator that insulates those hurts so you don't have interference

Sent from my SM-A102U using Lake Ontario United mobile app

Share this post


Link to post
Share on other sites

Same spark plug fix on my 1992 75hp merc. Night and day. Mine was shutting off.


Sent from my iPad using Lake Ontario United

Share this post


Link to post
Share on other sites

Just a follow up report on my fish hawk problem. I took BAITNH advise and called them while on the water for trouble shooting. They were great put me on with a technician and went through everything and in the end he thought it was a bad temp sensor in the probe. I sent it to them, they checked and sent me a new one no charge and just a few days turn around. I am very happy with the customer service, seems like not to many company's are this good to work with.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...