Jump to content

Moore sub troll issue


Recommended Posts

I am trying to figure out why my unit reads temperature no problem but nospeed? Needle just sits at zero. It never went wonky or anything just quit working. Tried a couple different new batteries, tested rca cable. Tried the damp cloth trick over receiver for better signal, checked coated cable. Nothing seams bad. Did a visual of circuit board nothing obvious. Curious if anyone has had this problem and a fix? Been tough without it with the currents.

 

 

Sent from my iPhone using Lake Ontario United mobile app

Link to post
Share on other sites

I’ve tried wrapping with wet cloth didn’t help. I’m not getting anything for speed from surface down anywhere. What wheel are you talking about? On probe? I can see that spinning when I put it down couple feet. Couldn’t check head end of unit didn’t see a way to open it up. Thinking I may have to just mail it out to have it diagnosed. Just didn’t want to be without. Like I said it reads temp no problem and I can judge speed ok ish just by the pull on my dipsy rods. Had some crazy currents so just makes life easier.


Sent from my iPhone using Lake Ontario United mobile app

Link to post
Share on other sites

Take a look inside the head unit and see if spider webs may be causing the problem. Happened to me several years ago and that was it. That analog needle is very sensitive

Link to post
Share on other sites

Did you check to see that the impeller type paddle wheel is functioning properly at that end of things?

Edited by Sk8man
Link to post
Share on other sites

Did you drop, mine at one time stopped working speed wise, I had it repaired and they found needle at pivot point was damaged, I was advised when trailering boat remove head unit because of shock from hard bumps on roadway will damage pivot because it’s very delicate. Been doing this for the past 10 years never had another problem. This is what I was told from manufacturer.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...